Help! Engine Cutting While Riding

Playground of the Techies. The place for resolution of more detailed questions and problems. Attempts to start The Tyre Thread or The Oil Thread in here may result in personal injury.
DanielG
Posts: 19
Joined: Mon Sep 09, 2019 2:16 pm
Current ride: XB9S

Help! Engine Cutting While Riding

Postby DanielG » Fri May 13, 2022 7:50 am

Hi All,

I'm having an issue with my XB12SS. While riding along the engine cuts out, it will start again when the bike has cooled down after a few minutes.

I have replaced the spark plugs, spark leads and ignition coil...

I feel like it's fuel related, but let me know what you think.

:ffs:

Thank you!
Dan

User avatar
TOPGUMM
Posts: 2932
Joined: Fri May 22, 2009 6:43 pm
Current ride: S1`s
Location: Llanelli South Wales

Re: Help! Engine Cutting While Riding

Postby TOPGUMM » Fri May 13, 2022 10:36 am


User avatar
barney
Posts: 3632
Joined: Mon Nov 07, 2011 7:10 pm
Current ride: Buell ulysses
Location: Telford

Re: Help! Engine Cutting While Riding

Postby barney » Sat May 14, 2022 7:35 am

:askmaz: or better still, go see him :idea:
Buell Ulysses XB12X 06/08

DanielG
Posts: 19
Joined: Mon Sep 09, 2019 2:16 pm
Current ride: XB9S

Re: Help! Engine Cutting While Riding

Postby DanielG » Tue May 17, 2022 7:24 pm

Thanks all, appreciate the help. I believe it might be related to the pickup sensor…

User avatar
kevmean
Posts: 7229
Joined: Wed May 06, 2009 5:28 pm
Current ride: 1991 RS1200 westwind

Re: Help! Engine Cutting While Riding

Postby kevmean » Tue May 17, 2022 8:04 pm

There's a very good chance that it is as it sounds very much like the issue I had with my X1 a few years ago, with the X1 it was a wiring fault from the sensor to the ecm
2001 X1 2009 1125CR 2006 Uly X3 2010 Uly a fully Maz'd S1 and a 1991 RS1200 Westwind.


Return to “Technical Forum”

Who is online

Users browsing this forum: Bing [Bot], Brandwatch [Bot], CommonCrawl [Bot] and 2 guests