Last visit was: Fri Oct 20, 2017 3:46 am It is currently Fri Oct 20, 2017 3:46 am

All times are UTC+01:00




 [ 45 posts ]  Go to page 1 2 3 Next
Author Message
PostPosted: Wed Jan 18, 2017 12:34 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
Ok so the above bike has been tested with buelltooth/ecmdroid ,all components work ,,suggesting that the wiring is also Ok ,please correct me if I'm wrong,the bike has no spark and with ign on no power at coil socket pos or neg same with starter pressed,stator and voltage regulator check out OK with avo meter,btw with plugs out for testing motor spins strong and Battery is strong and fully charged ,but with plugs refitted hard to turn engine,I have a 2nd ecu to test with and when used to look for spark when switching on ign I have an unbroken lightning spark from the plug for the time it takes for fuel to prime and V light go out ready to start,,,push the start button and no spark,any advice would be gratefully received


Top
   
 
PostPosted: Wed Jan 18, 2017 1:49 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
What happens if you pull the clutch in?

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 2:11 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
Clutch in or out does the same


Top
   
 
PostPosted: Wed Jan 18, 2017 2:15 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
Does it spark with interactive test?

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 2:40 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
I'm confused with wiring the colours changed at the coil plug I have grey/purple ,,,,grey,,,,,,,and black/red ,,, having continuity on blue/Orange at the black ecm plug ,,shouldn't they be the same colour,also does it make a difference being a Japanese and model ?


Top
   
 
PostPosted: Wed Jan 18, 2017 2:41 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
Hmmmm, that seemed to be the answer to a different question...

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 2:44 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
On active tests everything works as it should on all components


Top
   
 
PostPosted: Wed Jan 18, 2017 3:07 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
So, the answer is YES, you can see a spark at the plug during interactive tests???

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 3:19 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
Perfectly which is why I assume wiring is ok


Top
   
 
PostPosted: Wed Jan 18, 2017 3:22 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
:yup:

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 3:25 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
I did all the tests,fan injectors coil f/r fuel pump rpm meter only went to 3000 rpm on test but sweeps ok on ign on as does speedo ,V light,goes out and stays off


Top
   
 
PostPosted: Wed Jan 18, 2017 3:37 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14105
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
You obviously know what you are doing so apologies for repeating what you have already said or found out...

1. The plugs work
2. The leads work
3. The coil works
4. The harness between ECM and coil works
5. ECM output circuitry works

You haven't tested:
1. ECM input circuitry
2. Harness between ECM and crank position sensor
3. Crank position sensor
4. Any safety circuit (but you told me the clutch lever didn't make a difference)

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Jan 18, 2017 4:18 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
That's correct ,I havnt tested crank sensor and ecm input,I'm no expert but I try I just love it I'm trying to help the owner he loves it but he's spent so much money I fear he may lose interest he keeps going to different thai garages an they know nothing bot take lots of money in UK we would visit with sticks the last shop has had it for a year. !!! It's a beautiful bike and when it runs goes like thunder


Top
   
 
PostPosted: Wed Jan 18, 2017 4:23 pm 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
Clutch no difference I put test light in plug and it connects when lever is pulled,I'll test your recommendations tomorrow I've had enough today 10hrs reading and testing but thanks anyway for advice


Top
   
 
PostPosted: Thu Jan 19, 2017 11:52 am 
Offline

Joined: Thu Nov 10, 2011 1:06 pm
Posts: 159
Current ride: xb9snsrmc18tdr250
Location: thailand
Good morning,tools I use ,I have a probe that can supply pos/ gnd ,, red or green light can also test if I have pos/gnd, and I use a multi meter, I tested the supply to ecm OK ,I tested crank sensor wires to ecm OK, for continuity when I test with probe instead of bright green or red light I have a dim green which goes dimmer with him ON,when the ign has cycled V light out if I push the blue wire with my probe the coil cycles ???I don't clearly understand how to test the actual crank sensor


Top
   
 
 [ 45 posts ]  Go to page 1 2 3 Next

All times are UTC+01:00


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited