UK Buell Enthusiasts Group
http://www.ukbeg.com/forum/

Megalogviewer and ECMSpy?
http://www.ukbeg.com/forum/viewtopic.php?f=8&t=22427
Page 1 of 1

Author:  buford [ Fri Jun 16, 2017 11:04 pm ]
Post subject:  Megalogviewer and ECMSpy?

Hey guys-trying to set up MLV HD to create new fuel maps using wideband o2 sensors for my 2008 XB9SX. Connect to the ecm via ECMSpy Mono. Connects fine..logs data fine. But maps are wither waaay too rich or lean. When viewing the data logs, don't see any 0-5 volt readings? Not sure if the ecm is not configured correctly or MLV settings? I've chosen just about all the combinations for the EGO and AFR fields.

thanks for any help/suggestions you may pass along

Author:  pash [ Sat Jun 17, 2017 6:57 am ]
Post subject:  Re: Megalogviewer and ECMSpy?

Post some screenshots

Author:  gunter [ Sat Jun 17, 2017 12:08 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

buford wrote:
Hey guys-trying to set up MLV HD to create new fuel maps using wideband o2 sensors for my 2008 XB9SX.


If you try to set up the closed loop section, you will likely fail. MLV does not work well for DDFI. Main reason is that MLV focusses on the MegaSquirt EFI, where both ways, how to interpolate fuell map cell values for the current point of operation and how to compensate fuel when a lean/reach threshold is hit, are well known. This is not the case with DDFI. Using the dynamic maps in EcmSpy provides much better results with less rides (4-6 in average), although requiring more manual work.

Author:  buford [ Sat Jun 17, 2017 7:55 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

Setting up the new tables for open loop config. MLV worked great when doing this on the 07 Buell. That was 10 yrs ago and have forgotten what settings I used for MLV (EGO field and ARF field). Not sure what the dynamic logs are but would surely be open to trying that? I notice there is a wideband enable option in Mono. Is it required that the sensors are enabled to get usable voltages for MLV input?

thanks!

Author:  buford [ Sat Jun 17, 2017 8:18 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

Here is the last data log file..I think I've attached it correctly..This was done without enabling the wb sensor and tied into pin #32 on the ecm connector. Stock nb has been disconnected of course.

Author:  buford [ Sun Jun 18, 2017 6:10 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

OK-small update..

The dual wideband sensors are connected to ecm via pigtails at pins 1 and 33. Sensors are set to output their 0-4.096 volts. Connect the running bike to ecmpspy and then enable live viewing of data. Activate (I think..) the sensors. When I press activate the small window toggles from innactive to "timeout". Should it toggle to "active" at this point? On the live runtime page it shows O2 volts for F and R. Front holds at 0V whereas Rear oscillates between 0.49 and 0.50V. Then it does show Lambda 1 (Front?) and Lambda 2..but both read 0.00? So, Mono is reading something from the sensor output but not full voltage or maybe not fully activated?

Author:  buford [ Thu Jun 22, 2017 11:58 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

Update..finally seeing some usable Voltage data when the NTK wb gauge is connected to pin #32. Now making a really custom linear curve for MLV to chew on. Idles at 13.7:1 and 1.57V. Need to reduce the map counts until there is stable idle at 16:1 and plug those V data into the curve. This is a hyper open loop config.

Author:  buford [ Sun Jun 25, 2017 9:42 pm ]
Post subject:  Re: Megalogviewer and ECMSpy?

NTK gauge read 4.5V in free air with the voltmeter, but ecm was outputting only 3.08V. Probably something to do with current possibly. Anyways, created a custom voltage/afr curve for MLV and its working awesome. The key was tying into pin #32 instead of 1 or 33 to get useful voltage numbers.

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/