UK Buell Enthusiasts Group
http://www.ukbeg.com/forum/

Electrical fault with ignition and brake light.
http://www.ukbeg.com/forum/viewtopic.php?f=8&t=22384
Page 1 of 1

Author:  FerrisBueller [ Tue May 30, 2017 9:08 pm ]
Post subject:  Electrical fault with ignition and brake light.

Right, I've just swapped an XB lightning tail onto my 1125CR, and was trying to start it up, but no luck. The display turns on, I heard the fuel pump, but it doesn't start. No clicking or anything, the battery is good and freshly charged. Kill switch and all fuses checked. It's as if I'm not pushing the ignition button. Also, the brake light doesn't turn on with the lever or pedal. I swapped the connection and tested the light, that's fine. It's as if something isn't connected somewhere, that powers the ignition and the brake light. I only disconnected 4 plugs and they're all back together. Any suggestions?

Author:  Nutah [ Tue May 30, 2017 9:11 pm ]
Post subject:  Re: Electrical fault with ignition and brake light.

i would recheck the plugs you have touched,you may have a pushed back pin
in one of the plugs :?:

also take try taking the rear lamp out , then re try as a broken filament
can flap about & cause a short too

Author:  FerrisBueller [ Tue May 30, 2017 9:27 pm ]
Post subject:  Re: Electrical fault with ignition and brake light.

Horn, high beam and rear indicators also don't work. I suppose there is one thing that these share, with nothing else.

Author:  FerrisBueller [ Tue May 30, 2017 10:03 pm ]
Post subject:  Re: Electrical fault with ignition and brake light.

Got it. Kill switch.

Nah only joking, there was another wire that needed to be bolted to the negative on the earth. :oooops:

Author:  Nutah [ Wed May 31, 2017 6:03 pm ]
Post subject:  Re: Electrical fault with ignition and brake light.

glad you sorted it :yup:

Page 1 of 1 All times are UTC+01:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/