Last visit was: Tue Oct 24, 2017 4:19 am It is currently Tue Oct 24, 2017 4:19 am

All times are UTC+01:00




 [ 16 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Fri May 08, 2009 2:58 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
I often get the oil pressure lamp lit at the XB12 when the engine is hot - e.g. stop and go in the city. I first assumed it's a defective pressure switch or a chafed/grounded cable, but when listening, I can hear the tapets knocking. The noise disappears as soon as the oil lamp gets off again. This typically happens when in idle (~1000 rpm) or at low rpm.

So I assume the pressure switch is working as intended. Oil viscosity is 10W40 or 15W50, can't tell anymore if I changed oil before or after getting a new charge. What might be the reason for the low pressure? Do i need a new oil pump?

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Fri May 08, 2009 3:15 pm 
Offline
Moderator
User avatar

Joined: Wed Apr 15, 2009 5:25 pm
Posts: 11404
Location: Oswestry
My first thought would be to use the correct grade of oil ie 20/50.

_________________
If your dreams don't scare you, they are not big enough.


Top
   
 
PostPosted: Fri May 08, 2009 3:26 pm 
Offline
User avatar

Joined: Wed May 06, 2009 3:15 pm
Posts: 136
Current ride: XB12X
Location: Deutschland
:yt:

_________________
To Lands End and beyond


Top
   
 
PostPosted: Fri May 08, 2009 6:33 pm 
Offline
User avatar

Joined: Wed May 06, 2009 8:14 pm
Posts: 73
Location: Ashford, Kent
hi Gunter ,i think your idle speed is too low, my xb is 1050rpm hot ,also best on HD engine oil HTH ...........whichway?

_________________
........have you tried turning me off & then turning me on again ?


Top
   
 
PostPosted: Fri May 08, 2009 7:03 pm 
Hi Gunter.

As I recall 20W50 was made for air cooled V-Twins in the first place. Why are you not using the right grade of oil as per HD. Stick to the same brand oil, I use Torco and the K&N oil filter, and change at 2.5K or less.

Pressure test the oil system, if needed, after using the right grade of oil and a new filter. If the oil light still comes on do not continue to run it. It should be fine at 1000rpm hot. Mine is.

The oil is part of the cooling system and vital on a Buell.


Last edited by THE FLYING DUCHMAN on Fri May 08, 2009 7:21 pm, edited 4 times in total.

Top
   
 
PostPosted: Fri May 08, 2009 7:12 pm 
Quote:
but when listening, I can hear the tapets knocking.


The tapets are Hydraulic and low oil pressure or the wrong grade oil will cause this. The wrong grade oil is a common mistake and can be a killer.


Top
   
 
PostPosted: Fri May 08, 2009 7:30 pm 
Offline
Site Admin
User avatar

Joined: Wed Apr 15, 2009 5:17 pm
Posts: 7812
Location: Manchester
Just delete the problem using EcmSpy :idea:

_________________
Mithered ta death.
92 MB
96 S2T
98 S1W
00 M2
01 X1
03 P3
10 CR


Top
   
 
PostPosted: Fri May 08, 2009 7:32 pm 
Offline
Moderator
User avatar

Joined: Wed Apr 15, 2009 5:25 pm
Posts: 11404
Location: Oswestry
or take the warning lamp out :o

_________________
If your dreams don't scare you, they are not big enough.


Top
   
 
PostPosted: Fri May 08, 2009 7:37 pm 
Quote:
Just delete the problem using EcmSpy


A handy one to know this is :rofl:.


Top
   
 
PostPosted: Sat May 09, 2009 6:38 pm 
Offline
The Nagged Hubby
User avatar

Joined: Wed May 06, 2009 9:18 pm
Posts: 1094
That oil could be like water when hot Gunter, get a good Diesel grade 20/50 in her asap.

Nate.


Top
   
 
PostPosted: Sat May 09, 2009 8:01 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
Oil in engine was 10W50, I found an old bottle. I will give it a try and change to 20W50 as soon as I have some, but my experience tells me, that MY bikes do not like easy solutions. The gerotors look like new, clearance is within limits, the oil pump gear (golden one) shows some wear (IIRC it would be in now for about 7000 mls), so I exchanged it for the unbreakable from LuckyHands.

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Sat May 09, 2009 8:16 pm 
:rofl:


Top
   
 
PostPosted: Sun May 10, 2009 7:25 pm 
Offline
User avatar

Joined: Sun May 10, 2009 6:19 pm
Posts: 38
Current ride: Uly and two Nortons
Location: Staffordshire and ex t'Antarctic
Gunter, I'm amazed and aghast at a technical type chap like yourself running your bike(s) with basically the wrong oil in it, and then finding that you have major engine failure on your Buell.
HD's own 20W50 is the correct oil for your bike, put it in a crack on!


Top
   
 
PostPosted: Sun May 10, 2009 9:06 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
Gemach, gemach, mein guter Freund.

The bike's ready, awaiting an oil refill (and a new front isolator). We'll see then if 20W50 will give better results than 10W50.

Well, I am pretty sure to know the answer already ...

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Sun May 10, 2009 9:08 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14108
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
gunter wrote:
Well, I am pretty sure to know the answer already ...


Pray tell germanic friend...

_________________
08 Specialized Langster


Top
   
 
 [ 16 posts ]  Go to page 1 2 Next

All times are UTC+01:00


Who is online

Users browsing this forum: CommonCrawl [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited