Last visit was: Sun Nov 19, 2017 7:46 am It is currently Sun Nov 19, 2017 7:46 am

All times are UTC+01:00




 [ 17 posts ]  Go to page 1 2 Next
Author Message
PostPosted: Sat Jun 23, 2012 6:02 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
The latest firmware installed to DDFI-3 ECM types (BUE2D...) will make the fan run constantly if speed hits a certain threshold (15 mph or so).

If you want to go back to the "old" style of fan operation, you can do so by clearing bit 5 in the Fan Configuration byte. This can be done in TunerPro (see screenshot below) or by subtracting 32 (decimal) from the current value in the EEPROM window of EcmSpy (at offset 03C9 for BUE2D). If the current value is less than 32 (decimal), then this "feature" is disabled already.

If you want to keep the new style of fan operation, please note: the stock temperature thresholds seem more than just questionable to me, it's up to you to find out some reasonable temperature limits and change the tables accordingly.

This picture shows the stock setup in TunerPro:
Image

(You will most probably have to download the latest bin-Definitions from your personal download area at ecmspy.com to make these tables show up in TunerPro.)

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Sat Jun 23, 2012 6:56 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14157
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
Nice work...

_________________
08 Specialized Langster


Top
   
 
PostPosted: Sat Jun 23, 2012 8:45 pm 
Offline
User avatar

Joined: Tue May 05, 2009 8:00 pm
Posts: 8121
Current ride: Buell X1 2001
Location: southampton
:yt: :yup: Gunter 8-)

_________________
Obey the principles without being bound by them.
Bruce Lee

2001 X1 :4roz:


Top
   
 
PostPosted: Sat Jun 23, 2012 9:51 pm 
Offline

Joined: Mon Jul 25, 2011 10:43 pm
Posts: 166
Current ride: ulysses
Location: high wycombe
I do'nt even play with my ECM thingy but I still find Gunter's post's interesting and informative. :yup:


Top
   
 
PostPosted: Sat Jun 23, 2012 10:25 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
A small teaser ;)

Image

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Sat Jun 23, 2012 10:35 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14157
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
New MonoSpy feature then...

_________________
08 Specialized Langster


Top
   
 
PostPosted: Tue Jul 24, 2012 11:09 am 
Offline
User avatar

Joined: Mon Oct 31, 2011 7:55 pm
Posts: 433
Current ride: 1125r -stretched
Location: solihull
There are some strange things going on temperature wise on the the 1125s but it may be down to misquotes of certain temps.

In the workshop manual it states 83c as thermostat opening in the early specs,later in the same manual is says 73c ???

Also heard that the fans are set to run at speed due to them being a restriction to air flow. But don't know if there's any truth in that.

I'm still using a zd,but if we ever have time at the race track I'd like to put my current maps into my 2d and see if there is any difference.

there are obvious differences between the 2, one I noticed is temp corrections. the zd pulls timing at wot,but I've been unable to see it in logs.Maybe log still shows set timing not actual.
If it is pulling timing then it will be hurting my power. :(

_________________
Nige...1125d 9.43@140mph


Top
   
 
PostPosted: Mon Aug 13, 2012 8:35 am 
Offline
User avatar

Joined: Sun Aug 12, 2012 11:51 pm
Posts: 2
Current ride: 1125r
Location: Suffolk, England
Just popped in to say thanks Gunter, Nigel was kind enough to re-map my 1125R with your software at the Bulldog Bash this weekend, great work mate, its really made a lot of difference, thanks for all the time it must of taken you to put it together!
Ran 11.2 quarter mile totally standard and 10.9 following the tweak, K&N and other bolt-ins needed I think!!


Top
   
 
PostPosted: Mon Aug 20, 2012 6:22 pm 
Offline
User avatar

Joined: Wed Nov 18, 2009 4:35 pm
Posts: 338
Current ride: XB12XT
Location: Kildare, Ireland.
Have a 2009 Buell XB12XT....its got the latest Buell/Harley mapping....the one which has the fan running all the time...............Iwant to go back to the quirky one where the fan would run for a while after you switched off the bike !!

However I have a TWIN/Fuel Solutions Nl custom fuel mapping (remotely loaded) on my bike - got this after I fitted a K&N air filter (stock exhaust).

Would this make it hard, impossible or dangerous to try tweak it to get the "quirky" running fan setup again ?????

Eric.

_________________
'09 XB12XT
'02 Beta Alp 200
'82 + '83 CX500 euroSports's
'83 CX650 Custom
Green "4 Legged" SUV


Top
   
 
PostPosted: Mon Aug 20, 2012 6:36 pm 
Offline
proff. patpending
User avatar

Joined: Wed May 06, 2009 8:20 pm
Posts: 14157
Current ride: Victoria Sponge
Location: Bristol - Gateway to all things good
No

_________________
08 Specialized Langster


Top
   
 
PostPosted: Wed Sep 19, 2012 8:27 pm 
Offline
User avatar

Joined: Mon Feb 13, 2012 10:36 pm
Posts: 18
Current ride: XB12Ss 2009
Location: Madrid
Hello,

I friend with an Uly is trying to do the opposite, so having the "comfort kit" running for the fan. The problem is that he has a BUEZD ECM and is having problems to upgrade it to a BUE2D at the HD dealer.

Do you know if this feature is implemented in the BUEZD ECM? and if it is, do you know which bite should control this?

thanks for your help :yup:


Top
   
 
PostPosted: Wed Sep 19, 2012 8:56 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
From what I know only BUE1D and BUE2D have this feature implemented.
Easiest way to get it, is to upgrade to BUE2D at a H-D shop.

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Wed Sep 19, 2012 9:13 pm 
Offline
User avatar

Joined: Mon Feb 13, 2012 10:36 pm
Posts: 18
Current ride: XB12Ss 2009
Location: Madrid
gunter wrote:
From what I know only BUE1D and BUE2D have this feature implemented.
Easiest way to get it, is to upgrade to BUE2D at a H-D shop.


Thanks a lot Gunter! we're trying to avoid H-D, but... thanks again :yup:


Top
   
 
PostPosted: Wed Sep 19, 2012 9:18 pm 
Offline
User avatar

Joined: Wed May 06, 2009 6:18 pm
Posts: 1596
Current ride: CB1300 & Z750R
Location: Esslingen/Neckar, Germany
upgrading the firmware is one of those pretty rare things, where even them can't screw something up.

_________________
"It is often said that before you die your life passes before your eyes. It is in fact true. It's called living."
Terry Pratchett


Top
   
 
PostPosted: Mon Apr 15, 2013 12:39 pm 
Offline
User avatar

Joined: Thu May 26, 2011 5:06 pm
Posts: 19
Current ride: XB12Scg
Location: West Sussex
"by subtracting 32 (decimal) from the current value in the EEPROM window of EcmSpy (at offset 03C9 for BUE2D). If the current value is less than 32 (decimal), then this "feature" is disabled already."

I'm about to attempt this but having difficulty understanding what **** the above means. Any chance of screenshots or more detailed help... Cheers in advance..


Top
   
 
 [ 17 posts ]  Go to page 1 2 Next

All times are UTC+01:00


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB® Forum Software © phpBB Limited